Jak nazwać funkcję podmieniającą całość na podzbiór?

0

Szukam generycznej nazwy funkcji, która brałaby jakąś całość, i zwracała podzbior/child/element/mniejszą część tej całości.

Np:

  • Funkcja podmieniająca cały film video na pojedynczą klatkę.
  • Funkcja podmieniająca cały post na jedno zdanie.
  • Funkcja podmieniająca słowo na jedną litere.
  • Funkcja podmieniająca całą scenę 3d na jeden obiekt
  • Funkcja podmieniająca folder hello/ (w którym jest plik file.txt), na plik hello.txt.
  • Funkcja podmieniająca plik archive.zip (którym jest folder siemka/foo/bar/), na folder archive/foo/bar/
  • Funkcja podmieniająca obrazek 100x100 pikseli, na jego podzbiór, czyli na np wycięcie 50x50 pikseli od 20x30 left/top.
  • Funkcja podmieniająca int a = 123; na podzbiór, czyli na int a = 2;
  • Funckja podmieniająca całą farmę na jedno zwierze.

Coś odwrotnego jak "building". Nazwa funkcji powinna dawać do zrozumienia że funkcja bierze jakąś całość, i zostawia (i.e. usuwa wszystko oprócz) jakiejś jednej części/elementu.

2

Normalnie nazywa się to filter albo reduce w zależności od tego co robisz ;] W twoim przypadku brzmi to bardziej jak tworzenie tzw klas równoważności więc equivalence class

4

Przy takim opisie to i map by pasował (projekcja po polsku).

0
Afish napisał(a):

Przy takim opisie to i map by pasował (projekcja po polsku).

.map() sugeruje że może zamienić wszystko na wszystko, przeprowadzić transformacje, etc.

A intencja funkcji którą próbuję stworzyć jest taka że ma "zamienić coś na jego mniejszą część", "wyciągnąć mniejszą część z czegoś".

Shalom napisał(a):

Normalnie nazywa się to filter

Filter brzmi jak wzięcie A[] (o rozmiarze np 6), i wyplucie A[] (tylko o rozmiarze np 4).

albo reduce w zależności od tego co robisz ;]

Czyli...

reduce("/folder") // "hello.txt"

?

Może by i mogło być, gdybym nie znalazł nic innego, tylko problem jest taki. Tylko że reduce z reguły bierze "całą całość", np array, i pozwala wziąć wszystkie elementy pod uwagę przy podmiance. Ja chcę/potrzebuje tylko jeden. Np chciałbym podmienić cały folder jednym plikiem, a nie kilkoma.

W twoim przypadku brzmi to bardziej jak tworzenie tzw klas równoważności więc equivalence class

I wydaje mi się. Może rozwiń?

1

Może "crop"?

1

Coś odwrotnego jak "building"

To może decompose?

1

Jeśli ma zwracać tylko jeden element to może findFirst lub findAny, albo stare dobre get

2

ExtractSubelement / PickSubelement?

0

Funkcja podmieniająca

Jeśli ta funkcja ma zmieniać, a nie zwracać to jednak na pewno użyłbym replace w nazwie. Zaproponowane raczej zwracają element ale nie manipulują na oryginale.
Może coś w stylu replaceByfiltered()

0
yarel napisał(a):

Może "crop"?

crop("folder/"); // folder.txt

? No może by było.

cerrato napisał(a):

Coś odwrotnego jak "building"

To może decompose?

Brzmi jak usunięcie czegoś, trochę jak "dispose".

KamilAdam napisał(a):

Jeśli ma zwracać tylko jeden element to może findFirst lub findAny, albo stare dobre get

findFirst("folder/") // plik.txt
findAny("folder/") // plik.txt

? No nie wiem.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0