Aktualizacja Ubuntu z 17.04 do 17.10 rozwaliła system

0

Chciałem przeprowadzić aktualizację Ubuntu na serwerze VPS, jednak w trakcie wyskoczył następujący komunikat:

title

Teraz nie mogę nic zrobić, ani zainstalować ani usunąć, otrzymuję następujące błędy:

 libc-dev-bin : Depends: libc6 (> 2.26) but 2.24-9ubuntu2.2 is to be installed
 libc6-dbg : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 libc6-dev : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 libc6-i386 : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 libc6-x32 : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 locales : Depends: libc-bin (> 2.26) but 2.24-9ubuntu2.2 is to be installed

 Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Niestety komenda 'apt --fix-broken install' nie rozwiązuje problemu. Wersja kernela (uname -r) to 2.6.32-042stab127.2. To jest wersja z 2010 roku ??? :O Niestety chyba nie mogę zrobić aktualizacji. Jak to naprawić? Format to ostateczność, ponieważ będzie dla mnie bardzo niekorzystny.

0

No to zaktualizuj kernel

0

To jest serwer VPS OpenVZ, jedyne co mogę zrobić to downgrade bibliotek, ale jak?

0

Może spróbuj przez aptitude,

aptitude -f install

P.S. Co to za czerstwy dostawca, że siedzi na takim starym kernelu. Masakra jakaś. 2.6 już nie jest wspierany.

0

Z tego co czytałem to aptitude prawdopodobnie rozwiązałby problem, tylko że... nie mogę go zainstalować :D To jest wynik komendy sudo apt install aptitude

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 aptitude : Depends: aptitude-common (= 0.8.3-1ubuntu4) but 0.6.8.2-1ubuntu4 is to be installed
            Depends: libcwidget3v5 but it is not going to be installed
 libc-dev-bin : Depends: libc6 (> 2.26) but 2.24-9ubuntu2.2 is to be installed
 libc6-dbg : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 libc6-dev : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 libc6-i386 : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 libc6-x32 : Depends: libc6 (= 2.26-0ubuntu2.1) but 2.24-9ubuntu2.2 is to be installed
 locales : Depends: libc-bin (> 2.26) but 2.24-9ubuntu2.2 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
0

Jakim cudem kernel z 2010 roku pojawił się w systemie z 2017 roku?

0

Właśnie nie wiem, nie chce mi się do końca wierzyć, ale z Wikipedii tak wynika. Zapytałem dzisiaj o to support ale czekam już 10h na odpowiedź. Zazwyczaj odpowiadali w mniej niż godzinę. Chyba zadałem trudne pytanie.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0