Lazarus - indy10 i błąd linkowania w aplikacji konsolowej

0

Cześć,

mam zainstalowane komponenty Indy10 w Lazarusie i w programach graficznych bardzo fajnie się sprawdzają. Problem jest z aplikacją konsolową. Napisałam prosty program do wysyłania e-maili. Jest jednak problem z linkowaniem. Otóż aby umieścić komponenty w kodzie, wchodzę w Projekt->Inspektor projektu. Tam wybieram Dodaj->Nowy wymóg. W wyszukiwarce wpisuję "indy" i znajduję "indylaz". Dodaję to do wymogów. Teraz mogę dodać odpowiednie moduły komponentów, których chciałabym użyć. Jednak przy budowaniu programu otrzymuję ubogi komunikat:

project1.lpr(45,1) Error: Error while linking

Pogooglowałam trochę i znalazłam podobny problem: https://forum.lazarus.freepascal.org/index.php?topic=39818.0

Jednak zgodnie z poradą przy wykonaniu instrukcji

sudo apt-get install libgl1-mesa-dev

otrzymałam komunikat

libgl1-mesa-dev is already the newest version (20.0.8-0ubuntu1~20.04.1).
libgl1-mesa-dev zaznaczony jako zainstalowany ręcznie.

Problem nadal występuje. Co robię nie tak?

Pozdrawiam!

3

Jeśli chodzi o takie problemy, tym bardziej jeśli są związane z Linuksami czy platformami innymi niż Windows, naprawdę polecam pytać na forum Free Pascala – tam jest mnóstwo deweloperów używających *niksów, więc prawdopodobieństwo otrzymania merytorycznej pomocy jest znacznie większe niż tutaj. Mają tam kategorię Networking and Web Programming – spróbuj.

0

OK spróbuję.

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0