NUnit, nie mogę dodać nowych klas testów

0

Problem wygląda tak.

Zainstalowałem NUnit, dodałem do solucji projekt testów i napisałem kilka testów, wszystko działało. Po przerwie w programowaniu, musiałem przeinstalować Windows, Visual Studio i Nunit.
Otwieram stary projekt nad którym pracowałem i który zawierał projekt Testów. Wszystko się kompiluje bez błędów, program działa i testy się odpalają zgodnei z tym co było w projekcie. Stare Testy pisane wcześniej wykasowałem a napisałem nowe, mimo to przy uruchamianiu testów wyswietlają mi się wyniki testów które usunąłem z solucji (i z dysku) a moje nowo napisane testy nie są widoczne.

Konfigurację NUnit robiłem zgodnie z:
http://www.maciejaniserowicz.[...]/visual-studio-express-nunit/

a testy pisze zgodnei ze wskazówkami m.in stad:
http://www.cezarywalenciuk.pl[...]y-test-jednostkowy-NUnit.aspx

o co chodzi? gdzie jest problem dlaczego nie moge dodac nowych testów a uruchamiane są skądś stare juz skasowane przeze mnie testy?

1

Rebuild solucji robiłeś?
W testrunnerze ładujesz aktualne binarki?

0

Spróbuj zrobić (Build->) Clean Solution.

0

Cały czas robiłem tylko Build Solution (F6) i nie pomagało - Rebuild pomogło, dzięki.

Ale jeszcze dopytam, jak to działa, bo usuwałem cały projekt testów z solucji -> F6 -> dodawałem projekt testów -> F6 i właśnie nie pomagało, a dlaczego Rebuild pomogło od razu?

EDIT:

Podpowiedzcie jeszcze jak szybciej "używać" nowo dodanych testów czy świeżo dodanych przypadków testów?
na razie aktualizowanie testów i metod testowych mam dopiero po uruchomieniu aplikacji (F5), samo Build albo Rebuild nie pomaga - jest jakiś inny sposób niż F5?

1

Build: kompiluje wszystkie DLL i EXE które zostały zmienione.
Rebuild: kasuje wszystkie DLL i EXE i kompiluje wszystko na nowo.
Clean: kasuje wszystkie DLL i EXE

1 użytkowników online, w tym zalogowanych: 0, gości: 1, botów: 0